
Essentials One Training  Course No:  3HBA04





1

 Essentials One

Copyright © 2002-2009 Google, Inc.

Table of Contents:

Course Objectives							       2

Setting Your Template							       3

Creating Basic Geometry						      4

Want To Be Exact?							       5

Creating Surfaces From Circles					     6	

Creating Surfaces From Polygons					     6

Understanding The Stickiness Of Geometry				   7

A “Putting It All Together” Exercise					     9
	
Creating Basic Geometry In 3 Dimensions (3D)			   9

Drawing In 3D Using The Line Tool (pencil)				    11

Understanding Stickiness In 3D					     12

Using The Move Tool In 3D						      14

Keeping Things Coplanar: Autofold					     15	

Connecting And Generating Forms					     17

Generating Forms Quickly						      18

Restoring (Healing) A Surface						     19

Constructing A Building Footprint					     20

Creating Concentric Surfaces						     20

Drawing A Model Step-By-Step					     21

Mirroring In SketchUp							       23
	
Making An Array							       24

Applying Materials							       24

3D Text									         25  

Google 3D Warehouse							      26

Display Options And Styles						      28

Styles									         29

See Your Model In Google Earth					     30



2

 Essentials One

Copyright © 2002-2009 Google, Inc.

Mastering 3D Using SketchUp:  Essentials One Training

Course Objectives
Visualizing spaces in three dimensions is critical to the success of the design of architectural spaces. The 
interplay of light, color, space, and form make exciting spaces function successfully.  Traditional methods 
for exploring these issues are very labor intensive.  Use of computer software has enabled quicker (and 
sometimes more accurate) study models to be generated, explored, and iterated more times in the design time 
available to you.

SketchUp enables you to draw using a familiar pencil and paper paradigm in a software context.  The 
Mastering 3D Using SketchUp: Essentials One Training  course provides students with an excellent choice for 
beginning to learn to use SketchUp.  This course is intended for students with little or no 3-dimensional drawing 
or SketchUp experience, but who want to start to create 3-dimensional models using SketchUp.

To be successful in this course, you should already be able to: 
Define fundamental geometric terms including: polygon, parallel, perpendicular, axes, arc, and array. 
Define 3-dimensional drawing terms including: rendering, field of view, and point of view. 
Demonstrate mouse skills including: double-click, single-click, drag, and right-click (context-click).

* You will need a basic 3-button scroll wheel mouse to use SketchUp efficiently.

Upon completion of this course, you should be able to:
 

III1  Create 2-dimensional (2D) geometry in a 3-dimensional (3D) environment
	 • Create surfaces from lines
	 • Create surfaces from circles
	 • Generate surfaces from polygons
	 • Generate surfaces from arcs
Demonstrate stickiness of geometry
Create 3-dimensional geometry
	 • View a model in 3D
	 • Create surfaces from lines in 3D
Demonstrate stickiness of geometry in 3D
	 • Create geometry with the Push/Pull Tool
	 • Move entities to manipulate geometry
	 • Maintain coplanar geometry
Connect and generate forms
	 • Lock inferences
	 • Generate forms quickly
	 • Restore/Heal a surface
Create a model, step-by-step
Mirror a model
Create an array
Apply materials
Create 3D Text
Import (download) models from the Google 3D Warehouse
Alter a model using Styles
Import site information (imagery and topography) from Google Earth
Position and export models to Google Earth
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You can also access templates once you’re in SketchUp by going to the 
Window  menu and selecting Preferences  [Mac: go to the SketchUp menu, 
then Preferences].  Click on Template  at the bottom of the list on the left 
side and select the appropriate template.  Then click on OK and go to File 
> New  to create a new SketchUp file. *You won’t see your new template 
activate until you start a new file.  You can also create your own templates 
by modifying any of the existing templates to best meet your needs.  When 
you are ready to do this, go to File > 
Save As Template... and you can give 
it a Name, Description, and even set 
it as the default template every time 
you open SketchUp.  Once you save 
it, your new custom template will be 
accessible at the Welcome to SketchUp 
intro and also in System Preferences as 
described above.

Setting Your Template
SketchUp 7 opens with a ‘Welcome to SketchUp’ introduction 
window.  From here you can Learn more about SketchUp 
(through videos and documentation), view License details, choose 
a Template, or just start using SketchUp.  Click on ‘Choose 
Template’.  You will see a list of sample templates with various 
units, some of them show a human figure in perspective view 
with a visible ground and sky; these templates help new users 
understand SketchUp’s 3D environment.   Let’s scroll down and 
select a template called ‘Plan View - Feet and Inches’ near the 
bottom of the list, then click on ‘Start using SketchUp’.  For our 
purposes, this template is good because it allows us to begin a 
new SketchUp file looking down in a plan view so it will be easier 
to explore some of the basic functions of SketchUp.

sample template:
Simple Template - Feet and Inches

change to:
Plan View - Feet and Inches
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In SketchUp, you can draw lines by clicking on each individual endpoint or by dragging the second point 
of each line.  The clicking method (called click-move-click) is easier on your wrist, and insures that those 
beginning with the software will have better success at learning, since they leave their mind free between 
clicks to notice the screen without having to concentrate on holding down the mouse button.  The click-move-
click method will also ensure that you do not create small edge segments throughout your model by accident.  
These small segments can really cause havoc in a model.

Avoid dragging the mouse during edge (line) drawing.  The click-move-click method of drawing edges allows 
the edges to “chain” as they are drawn.  This means that until you form a closed loop of edges, the pencil will 
automatically continue drawing another line from the end of the last segment.  The dragging method of drawing 
a line will only draw one line at a time limiting your efficiency of drawing.

Note: At this point, it is good to review how the mouse buttons work.  There are three distinctly 
different terms you will hear when using a computer mouse: clicking (sometimes called left-clicking), 

dragging, and right-clicking (or context-clicking). 

Clicking the mouse means to hold the mouse 
still while pressing down and releasing the 
button.  It is critical that you not move the 
mouse during this process. 

Dragging the mouse means to press down 
on the mouse button and continue to hold it

down as you move the cursor
over the screen.  When you reach the desired location
on the screen, release the button to finish the operation.

Right-clicking (or context-clicking) the mouse means to click 
on the right mouse button (press down and release without 
moving the mouse).

Creating Basic Geometry

Creating Surfaces From Lines

To draw an edge, select the Line (pencil) Tool   from the Drawing toolbar.  Click somewhere on the screen 
(push the left mouse button down), then RELEASE  and move the mouse around (watch the cursor hover 
around on screen).  You will see a ‘rubber-band line’ extending from the start point to your cursor.  As you 
move the cursor, the rubber-band line will be black when it is not parallel with the axes (red, green, or blue).  
When the rubber-band line is parallel (or aligned) with one of the primary axes, its color will change to match 
the axis to which it is aligned.  Click the mouse button to complete the line segment and it will be drawn on the 
screen (this is the model area).  Now move the cursor down and draw a vertical edge.
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Want To Be Exact?

At any time while you are drawing a line, you can type an exact length and have SketchUp make precise 
geometry; try it.  Click to start drawing a line, then type a length like 10” or 20’ and hit ENTER.  The line will 
be drawn to that exact length.  SketchUp doesn’t require you to be precise but it allows you to define exact 
dimensions anywhere along the way.  Be as loose or as precise as you want.  If the line turns out a lot longer 
or shorter than you expected, remember SketchUp defaults to inches if you don’t type units after the number, 
so try it again.  Start drawing, type your dimension followed by the single quote (feet) or double quote (inches), 
then hit ENTER.  SketchUp displays this dimensional information in the lower right corner of your window, 
in an area called Measurements.  Notice that you don’t need to click into this Measurements area because 
SketchUp accepts numerical input during the drawing process.

Notice when the cursor is across from the start point on the screen, it shows a dotted line connecting the 
cursor to the other (start) point.  This is called an inference. In SketchUp, all geometry is interconnected and 
“knows” about the placement of other geometry.  To accept the inferred point, just click the mouse when you 
see the inference indication.

In SketchUp, all geometry consists of edges and surfaces.  The edges form a surface when all their endpoints 
meet, and when all those edges lie in the same plane (coplanar).  An edge can be straight or curved, but when 
curved - the curve must be coplanar with all other edges.

When you form a closed loop of coplanar edges, SketchUp puts a surface (or “skin”) on that wire frame.  
This surface can be erased by right-clicking (push down on the right mouse button when over an entity) or 
context-clicking on a Mac [hold the Ctrl key while clicking the mouse button over an entity and selecting 
Erase.  Notice that the edges remain when the surface is erased. 

Now select the Eraser Tool  and click on the top edge.  Notice that both the surface and the edge are 
removed (because surfaces are defined by closed edge boundaries).
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Creating Surfaces From Polygons

Polygon Tool    Polygons behave in a similar way. 

Note: You can change the number of segments used to draw the polygon prior to or 
even after placing the surface.  Just type in a number followed by the letter “s” (for 
segments), then hit the Enter (return) key. 

Change your polygon to 12s (twelve segments).  Try making it a 6s (six segments) polygonal surface, or 
3s.  You can also change the radius or the number of segments for a polygon through the Entity Info box, 
described below.  Remember that SketchUp will remember the last value you input - so the next time you use 
the Polygon or Circle Tool, it will have retained that value initially.

Creating Surfaces From Circles
Let’s look at drawing other shapes.  You can draw a circle using the Circle Tool .  Click once somewhere 
on the screen to place the centerpoint of the circle.  If you want to change the radius of the circle, just type in a 
number with units.  Try giving the circle a 10 foot radius (type 10’ and then hit the Enter [return] key).

Note: As mentioned before, the numbers and letters you type appear automatically in the Measurements area 
(Value Control Box) at the lower right corner of your SketchUp window.  If you prefer to see the Measurements 
box in different location, go to View > Toolbars > Measurements.  This allows it to act like any other toolbar in 
SketchUp.  You can dock it where you like, and it will return to the default lower right if you click the X to close 
the toolbar.  Any values you type as you model will appear in this Measurements area (except for text and 
dimensions you have in model space).  You can activate various toolbars in 
SketchUp by going to View > Toolbars  on a PC
[Mac: go to View > Customize Toolbar...].

You can also change the radius of the circle after it as been created by right-clicking [context-clicking] on it and 
selecting Entity Info (also accessed by Window > Entity Info).  This informative box gives you instant access 
to key attributes of all SketchUp entities, where you can view or edit the entities in your model directly from this 
box.  It may be useful for you to always have this box open while you are modeling.

After you have explored the Circle and Polygon Tools, start a new file by going to File > New.
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Understanding The Stickiness Of Geometry
You can draw lines that are not aligned to an axis; try creating a triangle.  Let’s explore how to think differently 
about geometry within SketchUp.  Any geometry can be ‘broken’ along its edges to modify its shape, like 
creating a star from our triangle.  With the Line Tool        selected, hover your cursor over different parts of the 
triangle.  Notice that some informative labels (inferences) appear when you hover (pause) over certain parts 
of geometry.  Move the cursor around (without clicking) until you see ‘On Edge’ (red square inference marker), 
‘Endpoint’ (green circle inference marker), ‘Midpoint’ (cyan circle inference marker), and ‘On Face’ (dark blue 
diamond inference marker).  By starting “On Edge” when drawing an edge, the vertex of the new edge has 
broken the existing edge at that point, creating a vertex at which three edges meet.

Notice the option to draw the new arm of the star as aligned to an axis.  Notice too, the inferences created from 
other vertices in the model.  This feature will be continually useful to you.  It’s like a virtual T-Square or 3D snap 
grid, without the hassle of specifically placing one.  If you start drawing a line and decide you don’t like it, you 
can always use the Esc key to cancel the tool operation and start again (works with most of the tools).

Take the Eraser Tool again, click and drag (hold the left mouse button down - and while continuing to hold it 
down, move it across the screen) the mouse cursor over both the interior edges you no longer need.  Then 
release the mouse button, and both edges are erased.
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Click on the Move Tool       .  As you move the cursor over the screen, notice that edges and surfaces get 
highlighted as you move over them.  This is called active highlighting, which allows you to act on geometry 
without needing to pre-select it with the Select Tool.  Several tools have this ability.  You can move entire 
surfaces, individual edges (line segments), or an individual vertex of an edge(s).  Keep in mind that you can 
always use the Select Tool       to pre-select geometry in your model before choosing the tool that you need.

Moving just vertices and edges, practice adjusting the surface to make it appear more “star-like”.  Notice that 
when moving a vertex or edge, all the attached geometry is affected also.  This is fundamental behavior for 
SketchUp.  Edges and points are shared between surfaces, allowing very plastic manipulation of the model.

Activity: 10 minutes to practice
Now take some time to experiment drawing lots of different shapes.  Use the Move Tool
on different parts of your shapes to explore how they affect each other.
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  Move arc  Circle, then Erase Freehand
edge to edge

Erase connected shapes

Rectangle       Line (from
      midpoint

         to midpoint)          Move vertex             Arc fillet
            on corner

A “Putting It All Together” Exercise

Creating Basic Geometry In 3 Dimensions (3D)

Viewing the model in 3D
In SketchUp, you are always working in a 3D environment.  So far we have been in a top or plan view, 
looking down on the model (notice the word ‘Top’ in the upper left of the screen). 

Draw a rectangle (15’,15’) on the screen and then click the Orbit tool        .  Now place the cursor near the 
bottom of your screen, click and drag (hold the left mouse button down - and while continuing to hold it down, 
move it across the screen) it upwards. Drag it right and left… see how the model’s blue axis (vertical) is now 
visible. The Orbit tool is used to navigate and examine your designs.
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If you have a mouse with a scroll wheel button, try 
rolling the wheel back and forth.  This will zoom you 
in closer and out farther from your model centered on 
the place the cursor is over.  Now try holding the scroll 
wheel button down while moving your mouse.  This 
activates the Orbit Tool - as long as you hold down the 
scroll wheel button.  Release, and you are right back 
to the tool you were using!  Try holding down the Shift 
key while clicking and dragging the scroll wheel; this 
activates the Pan Tool. *Using the mouse for naviagtion 
allows you to manipulate your model solely with the 
mouse, avoiding the need to pick most of the viewing 
tools.  It also speeds up your working process, because 
you are not distracted with viewing buttons while trying 
to draw or model.

Iso 
View

Top 
View

Front 
View

Left 
View

Back 
View

Right 
View

hold down middle scroll 
wheel + Shift to pan

Select the Pan Tool   .  Click and drag the cursor around on the screen.  This moves the 
model without changing the viewing direction.

Click on the Top View icon and the Iso 
View icon.  These can help you quickly 
orient yourself in 3D space.

press
down



11

 Essentials One

Copyright © 2002-2009 Google, Inc.

Drawing In 3D Using The Line Tool (pencil)
Let’s continue sketching; draw a rectangle and orbit the model to an isometric view. 

To draw a rectangular boxed volume, draw upwards in the blue direction from a corner of the rectangle.  Watch 
the cursor hint at the axis and turn to a blue rubber band line and report “On Axis” letting you know that you are 
perfectly vertical.  Hitting the Esc key cancels an operation in progress, and in this case can be used to ‘finish’ 
the line once you click a second time.  Draw a second vertical line in the blue direction.  Notice that it will also 
inference to the height of the first line when you go high enough.  Now complete the side of the cube.

Do the same for the other side of the cube.  Then orbit the model to see that the sides are truly vertical in 3D 
space.  You can always trace in edges in SketchUp to form surfaces.  This is the basic construction method.

It does not matter what order you draw the edges, just be sure that the sides of your cube are coplanar relative 
to the edges that bound each side.  Draw in an upper horizontal edge, parallel to the ground.  After you have 
drawn three of the sides, watch as you draw in the last edge… both the top and side surfaces of the cube are 
completed at once.  This is because each of those surfaces share that same edge.
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Understanding Stickiness In 3D
Using the Push/Pull Tool
Draw some edges on the top surface.  Make sure the edges start when the cursor dot turns red and says “On 
Edge”.  This insures that the new edge will break the existing edge into two edges.  Now take the Push/Pull 
Tool and click once on the new smaller surface you created.  Notice that it auto-highlighted that surface as 
you moved the cursor over it.  Now hover your mouse upwards on the screen and click a second time to end 
the push/pull operation.  Remember to click-release-click, and not to click-and-drag the mouse.

Now try moving the mouse downwards after you’ve clicked once to initiate the push/pull.  Anyplace you 
stop moving the mouse and click a second time, the surface will stay there.  This tool creates extrusions 
perpendicular to the starting surface.  Try pulling the surface down and click on the bottom edge (look for the 
red On Edge inference).  This subtracts that geometry because you’ve basically “cancelled-out” the surfaces 
(next page).

Orbit your model to check your work and get a good feel for orbiting around geometry in SketchUp.  SketchUp 
acknowledges a variety of inference points to help you model quickly and easily.  We’ve already noticed many 
of these in the 2D example, now get familiar with inferences on your cube in 3D.  In addition to the ‘On Axis’ 
inferences (red/green/blue axis inference lines), you’ll see On Edge, Endpoint, Midpoint, and On Face.  There 
are also inferences for Center (blue), Parallel to Edge (magenta line), Tangent (magenta line), and Intersection 
or From Point (black).
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Draw a circle on the front face of the new inner surface.  Use the Push/Pull Tool to extrude it, but this time we 
will explore a new inference.  When you are push/pulling, move the cursor over the front face and notice the 
inference line that extends from the face you are moving to the face you are touching.  This is letting you know 
that you are aligned exactly to that surface. Click there, and orbit to examine your results.

Go ahead and create more shapes by drawing new surfaces on the model and push/pulling them into new 
geometry.  Remember that you can always type in an exact dimension with the Push/Pull Tool just like any of 
the other tools.  Click once to start the push/pull, release and move your mouse in the direction you want to go, 
then type in a dimension.

Activity: SketchUp calisthenics
At this point, let’s look at a basic sequence of steps in SketchUp that begin most 
models.  Let’s practice it several times (kind of like push-ups: drop and give me 10!) 

The steps are: 
1.	 select the Rectangle Tool
2.	 draw a rectangle
3.	 select the Orbit Tool
4.	 click+drag the middle mouse button to get to an isometric view
5.	 select the Push/Pull Tool
6.	 extrude a cube along the blue (vertical) axis
Try this several times… rectangle, orbit, push/pull… start a new file and do it 

again… and again…



14

 Essentials One

Copyright © 2002-2009 Google, Inc.

Now push/pull them both into volumes and orbit the model as shown.  The Move Tool will not only move a 
surface, but all attached surfaces are affected as well.  When an edge is moved, all connected edges are 
affected as well.  You can move a surface, an edge, or a point where two edges meet.  In all cases, SketchUp 
will do its best to allow you to move in the desired direction while preserving your surfaces.  See the effect on 
the cube, and notice that trying to move the top surface or edge of the circle can only be done in the blue axis 
direction.

When a vertex is moved, all edges sharing that endpoint are affected.  If surfaces bounded by the affected 
edges are caused to become non-planar, SketchUp will automatically create fold lines (edges) to keep the 
surfaces planar.  Let’s undo-back until we get to having just the cylinder and the cube.  Hover the Move Tool 
over the curved surface until you see a dotted blue line highlight (there will be 4 of these at each quadrant of 
the cylinder).  Click and move the quadrant ‘midline’ to adjust the radius of the cylinder.  Do the same to adjust 
the radius of an arc or circle.  Move the cursor over the perimeter until only the midpoint/quadrant point is 
highlighted (and not the entire circle) and click then.

Using The Move Tool In 3D
The Move Tool creates different results depending on whether you move a face, an edge, or a vertex.
Draw a rectangle and place a circle next to it. 

Push/Pull Push/Pull Move Surface Move Edge

Locked in Blue Locked in BlueMove Point Move Surface
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Activity: 10 minutes to play
Go ahead and experiment with drawing different forms in 3D.  Try drawing one surface on another 
to subdivide them, then use Push/Pull on them to generate quick new forms.  Try the Move Tool on 
everything…

In the example model below, try moving the rectangle as shown.  Notice that SketchUp limits the movement 
and you can’t move this rectangle in the blue axis direction.  Sometimes when moving a surface or a vertex, 
SketchUp will only move in certain directions to keep the surfaces planar.  If you want to move in another 
direction, you must invoke the Autofold override using the Alt key on the PC [Cmd key on the Mac].  To move 
the vertex downward in the blue direction, first get the Move Tool and click on the vertex, then tap the Alt [Cmd] 
key and move in the blue direction.  Orbit to check your work.  Autofold is a toggle command, so you don’t 
need to hold the key down.

Try the Move Tool on a circle.  Notice how the highlighting changes when you find the quadrant point(s).  This 
is very subtle and allows you to change the radius, so be careful to orbit and zoom close enough to see the 
difference on screen. 

Take some time to play around with the concepts you’ve learned.  Experiment with drawing closed edge 
shapes on surfaces of varying orientations and move them, then push/pull them to explore the differences.

Keeping Things Coplanar: Autofold
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       Rectangle Push/Pull  Rectangle Move + Alt

(don’t forget
Autofold!)

 Push/Pull   Arc  Push/Pull finished!

Activity: Bringing it all together
Try drawing the following shape using the tools and concepts covered thus far.  Try creating it 
without referring to the steps below.  If you run into trouble, follow the illustrated steps below.
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draw the back 
rake edge

finish other side  draw the addition 
limits

draw  the footprint

Connecting And Generating Forms
Locking an inference	
Now that you know how the drawing tools for SketchUp work, let’s look at how to begin drawing complex 
interconnected forms.  The remainder of the examples in this seminar will be in ‘comic book’ form, where only 
new concepts will be elaborated upon, and all existing drawing skills are indicated with a simple caption or 
statement.  We will start by drawing a simple form.

We will create the form using only the Line (pencil) Tool and inference locking (holding down Shift while 
inferring).  You can also lock axis inferences by hitting and releasing the arrow keys on your keyboard.  Up/
Down arrows lock in Blue, Left arrow in Green, Right in Red.  Locking an inference keeps the tool aligned to 
a particular inference direction while combining that direction with another inference - either a point, direction, 
or surface.  This is to show you the power of this most basic tool in SketchUp.  If you are having trouble 
manipulating a form, you can always just pick up the pencil and draw it in! 

Let’s look at how to activate focus 
for an inference if it is not indicated 
automatically for you.  To do this, hover 
(move the cursor over the point or 
surface and pause for a moment, but 
don’t click!) over the point or surface 
you want.  In this case, we are focusing 
on the midpoint of the edge, then 
moving the cursor in the blue direction 
to establish the ridge height.  You see 
an inference message indicating “From 
Point”. 

Try it again to infer the ridge in the green direction across from the other end of the house form.

Note: You can also LOCK an inference using the 
keyboard ARROW KEYS, just start drawing and 
then click and release 
an arrow key:

Up & Down = Blue axis
Right = Red axis 
Left = Green axis 
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You have been inferring along directions and to and from points; you can also infer to a surface.  Start a 
line from the corner of the addition footprint and infer in the blue direction and lock it with Shift.  Continue 
holding Shift and click anywhere on the roof plane.  The pick point registers as the point directly up in the blue 
direction where that blue vector would intersect with the surface you indicated.  This will allow you to make 
the roof slope of the addition match that of the rest of the roof.  Try it again, locking the inference in the blue 
and select the height for the other vertical edge of the addition to the house.  Remember to move your cursor 
around until you locate the blue inference line, and THEN hold down Shift.

Rectangle Push/Pull using Line Tool, 
draw ridge line  

between midpoints

move ridge up 
with Move Tool,

watching for 
blue direction 

indication

Generating Forms Quickly
Now let’s look at another way to create this same house form; this time we will use more advanced tools.

Finish drawing the back sloping edge and erase the unwanted edge that divides the roof plane.

Reminder: This entire example was constructed using only the Line tool combined with 
inference locking.  Anything can be drawn with the pencil and this excellent geometry 
alignment engine!  If you get stuck, just pick up the pencil and draw it.
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Restoring (Healing) A Surface

Try another way to draw this form on your own using Push/Pull and Move.  Notice that Push/Pull is 
automatically locked in a parallel direction and infers other points.  Sometimes when erasing an edge, other 
faces get erased as well.  No problem.

Erase the line that divides the roof surface.  Since the two 
adjacent surfaces are now coplanar, erasing the edge creates 
one larger, more complex surface.  Remember to use inferring 
whenever possible.  This is your “3-dimensional T-square”.  It 
is the feature which, more than any other, gives SketchUp its 
power and versatility.

Just use the Line (pencil) Tool and trace over one of the edges from end to end.  All valid coplanar loops will 
be healed or filled in as surfaces.  Continue tracing edges until all surfaces are back. *If a surface will not heal, 
usually it is because the edges are not coplanar.  When possible, the face finder will fill in valid coplanar loops. 

Note: Sometimes you 
may have to triangulate 
between edges across 
an area to get a surface 
to fill in.  This often 
happens with input from 
CAD applications that 
have many disjointed 
line segments which 
confuse the face finder.
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Creating Concentric Surfaces

Another basic tool in SketchUp is the Offset Tool , which creates edges parallel to the perimeter of a 
selected surface (or to those edges selected) at a user-specified offset distance.  To offset edges of a surface, 
click once on the surface and then hover the mouse to start the offset.  Click a second time to set the new 
edges into place.  You can always type in a distance on the keyboard after the first click, and then hit Enter 
[Return], and the edges will be drawn that exact distance in the direction indicated.  Then Push/Pull the interior 
surface down to create a parapet wall.

Activity: 10 minute play time
Go ahead and play with SketchUp.  Know that you can always use the Line Tool,
or accelerate your geometry creation using Push/Pull and Move. 

Constructing A Building Footprint 
Lay a rectangle out on your ground plane.  We are creating a building that has a circular wing outcropping.  
Grab the Arc Tool and create a half circle along the edge (there is a half circle inference if you hover carefully 
as you create an arc).  You can eyeball the inset from the foundations on either side, or better yet, use 
inferencing to exactly match the center of the arc with the midpoint of the side (after you draw the arc).  To do 
so, use the Select Tool to pre-select the arc edge.  Now grab the Move Tool and hover along the edge of the 
arc until you get an endpoint indicated at the midpoint of the arc.  Click that endpoint and start moving the arc 
parallel to foundation edge.  Hold the Shift key down to lock that direction.  Now you can move your mouse 
to the back edge of the foundation and hover until you find the midpoint of that back edge.  Now use the 
Eraser Tool to erase the line dividing the arc surface and the foundation surface.

Push/Pull the building foundation up vertically.  Use the Line Tool to split the roof surface opposite the curved 
face and Push/Pull down to create the beginning of a balcony.
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Drawing A Model Step-By-Step
Let’s create something that we can use for mirroring and array examples.

Select 3 edges 
using Shift key 

to select multiple 
items

 Offset Tool   offset the frame Push/Pull
frame out

Push/Pull
door in

Draw a 35’,25’ 
rectangle

     Push/Pull form
     up 12’

    draw ridge edge       Move ridge
      edge 10’ up

       divide gable
       with edge

Create a balcony area from the lower section by offsetting the three edges and pushing the interior surface 
down… or we could make a sloping mansard.  Select the three edges (using Shift), and use the Move Tool to 
create the shed (remember Alt [Cmd] to activate Autofold!). 

Let’s draw a door (rectangle) on one side of the building.  Hold down the Shift key with the Select Tool to select 
multiple entities.  Using the Shift key with the Select Tool allows you to add/subtract geometry to/from the 
current selection set.
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Push/Pull rake 
eave 

   24” each side
   (double-click)

      Push/Pull eave
       each side

           by double-
          clicking

      inference lock
     along rake

infer to the 
opposite roof 

surface

   close ridge
  diamond surface

     Push/Pull ridge
     diamond

         Erase
         unnecessary

         edges

             draw rake

each side        Pull/Pull rake        draw chimney
       footprint

         draw in blue
         direction

       infer in green
       direction

Push/Pull one
side back 10’

Push/Pull roof
surface out 8”

   double-click
 repeats Push/Pull

  distance

   draw facia
   edge

       each side

draw back to roof         Push/Pull
   chimney

    finished house!   
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Now draw in a chimney by inferring in the vertical direction.  You can infer as you draw the edge
upwards, or you can be drawing above the surface of the roof and infer downwards from a point while 
continuing to draw above the roof surface.

Mirroring In SketchUp
Let’s select the house we just drew and make a mirrored version of it.  First copy the house using Ctrl with the 
Move Tool [Option with Move for Mac].  Using Ctrl [Option] to copy geometry is also a toggle command, so you 
only need to tap the key once to toggle on/off the copy function.

Review note: You can single-click on an edge or surface to select it.  By double-clicking on an edge or 
surface you select the edge and any attached surfaces, or the surface and any bounding edges.  By triple-
clicking on an edge or surface, you quickly select that entity along with any attached geometry extended to 
the outer limits of connectivity.

.

Select objects 
(triple-click)

Copy using 
Ctrl + Move or 
[Option+Move]

right-click
[context-click]

Select ‘Flip Along’,
and choose

axis direction

draw back to roof         Push/Pull
   chimney

    finished house!   
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Making An Array

Select (triple-click) make a copy
with Ctrl
[Option]

Type 4x
(for # of copies)

     Type 45’
     (for separation) 

   copy entire
   row over

...and flip them Camera menu > 
Position Camera

and click points
in the scene

Camera menu > 
Field of view

adjust
Field of View

Now we have an array of houses; that’s neat, we have a neighborhood.  Let’s save the file as
“My Neighborhood”  

You can also set the Field of View with the Zoom Tool .  The camera lens is likely shown in the 
Measurements box as 30.00 degrees.  To change the field of view, just type in a number when the Zoom Tool 
is activated; this number refers to the focal length of the ‘lens’ in SketchUp.  You can type in deg. or mm  after 
the number to specify the units. 

Applying Materials
Our neighborhood is still pretty boring, let’s paint some textures on our 
houses with the Paint Bucket Tool.

The Materials Browser will open automatically when you click the Paint Bucket Tool.  
Search through the categories of available materials.  Select a roofing material and 
apply it to the roofs of your buildings.  Do the same with the ‘Brick and Cladding’ 
category to find a nice siding treatment for your houses.  Finally, paint a brick texture 
on your chimney.  It’s as easy as clicking on the surface you want to paint!

(these steps are interchangeable and values can
   be overridden while still in this tool operation)



25

 Essentials One

Copyright © 2002-2009 Google, Inc.

3D Text
Creating 3D Text is a breeze.  Simply go to the TOOLS menu and select 3D Text.  3D Text has a lot of 
applications, but it basically allows you to turn words or phrases in a specific type face into SketchUp 
geometry that can be painted, scaled, and positioned in your model.  Some modelers will even do text 
treatments in 3D in a separate model to get exactly the treatment they want.  As with any SketchUp file, text 
files can be saved out as high resolution graphics. 

In the Place 3D Text dialog, type the text you want to convert into geometry.  Let’s review some of the options. 

					   
FONT - controls the style and shape of the letters
“Regul�ar” - this pull-down menu lets you choose attributes like
regular, bold, and italic when a font has those options
ALIGN - positions the word or phrase within its bounding area
HEIGHT - sets the height from bottom of the letter to top
EXTRUDED - sets the depth of the letters from the face to the 
back; if ‘Extruded’ is unchecked, the letters will have just surfaces 
and no depth
FORM - uncheck the ‘Filled’ box if you just want the outlines of 
the letter without surfaces

Type in “Arcadia”, select a font, and make sure that Filled and Extruded are selected.  Enter 10’ 
for the Height and 1’ for the Extrusion.  Click on ‘Place’.  The text is converted into geometry and 
it automatically becomes a Component.  Now you need to select a location for it in your model.  
Components will orient themselves to whatever surface you are on.  Let’s drop the text onto the 
ground plane.  Use the Move Tool to position and orient the text however you want.  Hovering over 
any of the RED CROSSES of the Component bounding box will allow you to rotate the text in certain 
directions.  You can also try using the Rotate Tool       for more rotation options.  We will cover the 
Rotate Tool in more detail in the next class.  
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Google 3D Warehouse
Now we have an arrangement of houses, but our 
neighborhood is still pretty stark.  It would be great 
if we could grab some trees and cars to add to the 
context of our model.  Fortunately, the Google 3D 
Warehouse is only a mouse click away!

The 3D Warehouse is a repository for everything
3D: doors, windows, appliances, fixtures, houses,
cars, buildings, trees, etc.  It is a virtual library of free 
models that anyone can upload to and download 
from, and is an easy way to add entourage to your 
models.  To access the Google Toolbar, go to
View > Toolbars > Google  on a PC
[Mac: View > Customize Toolbar...]

To search for and download models, 
simply click on the GET MODELS icon
to launch the 3D Warehouse within SketchUp.  
However, you might prefer to browse the contents 
of the warehouse directly from the Components 
Browser in SketchUp!  To do this, just go to
Window > Components.

You can type in search 
queries (try ‘trees’) in the 
search box just below 
the 3 tabs.  Click once 
on any search result to 
automatically have that 
item downloaded into your 
model.  The ‘View Options’ 
button to the far left of the 
search box lets you choose 
the way your search results 
are displayed.  The ‘house’ 
icon lets you view all the 
components currently in 
your model.  Using the 
‘Details’ arrow on the right 
side, you can save a 3D 
Warehouse search as a 
‘Favorite’ and download 
any warehouse collection 
for offline use!  Use the 
‘Navigation’ arrow to the 
left of the search box to 
access Favorites or
Recent search collections.

Search for ‘2D schematic juniper2 tree’.
This Juniper looks good; click on it once
to download it.  If you’re not searching

from the Component Browser, you’ll need
to click on the item you want, then click on 

Download Model.

use the Components 
Browser to explore
the contents of the

Google 3D Warehouse
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Click on Yes to download the item into your current 
SketchUp model (you’ll only see this prompt if you 
search the warehouse from the toolbar icon).  It’s 
as easy as that, the new tree component can be 
positioned anywhere in your model.  Drop it at 
some interesting location, and then orbit to verify 
that you placed it on the ground plane.  Now tap 
the Ctrl key with the Move Tool and you can make 
copies of the tree around your neighborhood.  

Let’s go back to the 3D Warehouse and grab some cars to finish out our scene.  Click on the ‘Get Models’ 
button or just type ‘car’ into the Components Browser search box and hit Enter.

Find a car you like and place it in your model.  The 3D 
Warehouse works just like the Google search.  If you don’t 
see something you like on the first page click on the ‘Next’ link 
to see another page of models.   After you get the car in your 
model, go back and try searching for “pickup truck”.  Grab one 
of the trucks and drop it in.  The 3D Warehouse makes it a 
snap to add entourage and complete the look of your model!
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Display Options And Styles
SketchUp gives you a great deal of control over how your geometry is displayed on screen and for printing.   

Display Options (Face Style)
In your menu, you should see a series of icons representing different modes for displaying your model.  If not, 
you can access this toolbar from View > Toolbars > Face Style.  Let’s see how our model looks in each of 
these modes.

The cube icon on the far left of this 
toolbar represents X-RAY mode.  This 
is a toggle that shows all surfaces, 
materials, colors, etc., but makes them 
transparent so you can see through 
the geometry.  Since it is a toggle, 
the X-ray mode can be on or off in 
combination with any of the other 
display modes.  The other display 
options are shown and described 
below.

Wireframe
no surfaces

Hidden Line
lines and surfaces,

no shading

 Shaded
  surfaces with colors

Shaded With 
Textures

Monochrome
Hidden Line with 
one color shading
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Styles
In addition to the display modes available in the menu, SketchUp allows you to apply a collection of display 
properties which we call a STYLE.  To apply a style, simple go to the Window  menu and select Styles.  

Applying styles is just as easy as clicking on one of the icons in 
the Styles Browser.  Check out the ‘Assorted Styles’ category in 
the pull-down menu and try some of those.  Styles are made up 
of various face treatments, which are the same as the modes 
described previously, but also include additional line and overall 
model treatments.  These assignable attributes include settings like 
background color, ground/sky, depth cue, line extensions, and halo.  
Styles also give you the ability to apply foreground and background 
watermarks, and can give your linework a variety of different 
appearances to help your model feel more sketched and loose, or 
make it look precise and finished.  Play around applying different 
Styles to see how quickly and easily you can completely change the 
look of your model.  Remember that applying Styles does not affect 
the actual geometry, it only changes the visual representation of it.  Be 
sure to save your neighborhood model to the desktop when you’re 
finished.

Sketchy Edges are very cool.  Rather than rendering your geometry in straight lines, various stroke 
treatments can be applied.  As you zoom away from the model, details drop away; just like in the real world!
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See Your Model In Google Earth
Finally, let’s take a look at a great free way to share your models and show them positioned in Google Earth.

Google Earth is free for anyone to download and 
browse.  It is really a virtual world.  As we said 
earlier,  Google 3D Warehouse is a repository 
of 3D models of all types.  The warehouse isn’t 
limited to just Components, it is also a storehouse 
for “geo-located” (or geo-referenced) models; that 
is, for models that have been exactly positioned 
in the virtual realm of Google Earth to match their 
location on planet Earth.

Let’s take a look at how that works - start by 
launching Google Earth.  Type in “Boulder, 
CO” and hit Enter.  We’re going to take our 
neighborhood model and position it in an open 
area near downtown Boulder.  Let’s zoom into 
the field and position our view so that we have 
isolated just the area that we want to model on.  
Now start a new file in SketchUp.  

In SketchUp, click on GET CURRENT VIEW  

SketchUp brings in a SNAPSHOT of the Google 
Earth view that contains both the satellite image 
and the topographical data for your site!  Go 
to Window > Layers  to see the Snapshot and 
Terrain on separate layers.  Here you can toggle 
on/off the visibility of the terrain with the Layers 
check boxes.  You can also do
this with the ‘Toggle Terrain’ icon.

zoom in and fill your screen 
with this open field so we can 
import this view into SketchUp

Note:  Before you click on ‘Get Current 
View’ in SketchUp, make sure your 

view in Google Earth is oriented 
perpendicular to the ground.  Use the 

keyboard shortcut “R” to Re-orient 
your view quickly to looking straight 
down and North pointing ‘up’ on the 

compass.  Also, make sure you don’t 
have any extra Layers turned on.  Any 
icon graphics and content in Google 
Earth that appear with certain Layers 
will also be included in your satellite 

image when it gets put into SketchUp.
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Now let’s bring in your neighborhood.  In 
SketchUp, go to the File > Import, select your 
saved neighborhood model, and click on ‘Open’.  
The entire model comes in as a Component.  

Now we can position the model in the context 
of our satellite site image.  Select the Move Tool 
and move the neighborhood to a location of your 
choosing in the open field.  You can also use the 
Move Tool to easily orient your neighborhood 
by rotating it with the red rotation grips on the 
Component bounding box.
Finally, orbit and zoom in SketchUp to a 
convenient isometric view of the neighborhood.  
The view seen in SketchUp will be the default 
view/orientation of your model for anyone 
browsing it, until you change it in Google Earth.

Google Earth launches and shows you your 
neighborhood in its exact latitude/longitude 
position on the globe!

Initially, this model will be a temporary file in the 
Places panel on the left.  To save this to your local 
hard drive, just click and drag the file up into the 
‘My Places’ category.  To make a public version 
of your geo-located neighborhood, simply click on 
the ‘Share Model’ button.

This will launch the Google 3D Warehouse so can 
easily create a log-in and then share your model.  
Now anyone who browses the 3D Warehouse will 
be able to access not just your model, but a
geo-located version of it as well!

rotate neighborhood 
to fit into field

once positioned, click on ‘Place Model’
to export model to Google Earth


